Symantec Netbackup

In this post i  will be discussing some of the issues that i have come across while administering a netbackup environment.

Restore job stuck as the tape goes into frozen state. If you unfreeze the tape from GUI it complaints with error “Already Allocated” and restore job will not move further.

Here is how we can fix this type of issue.

[1] From your master server go to following location and run command :

/usr/openv/netbackup/bin/admincmd/Nbrbutil –dump|grep < tape barcode >

example : masterserver$ nbrbutil -dump|grep 109026

MdsAllocation: allocationKey=41791 jobType=2 mediaKey=4001630 mediaId=109026 driveKey=0 driveName= drivePath= stuName= masterServerName=ebars04 mediaServerName=ebars04 ndmpTapeServerName= diskVolumeKey=0 mountKey=0 linkKey=0 fatPipeKey=0 scsiResType=0 serverStateFlags=0

Note : masterserver is the master server of your backup environment and you need to grep for the media id that is getting frozen.(109026 is the media id in this case)

[2] Note the allocation key highlighted above and run below command to release it

nbrbutil -releaseMDS 41791

Now you can rerun the restore and it will run without issues.

 

 

 

 

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s